What is this? From this page you can use the Social Web links to save No standard MySQL support in Postfix package to a social bookmarking site, or the E-mail form to send a link via e-mail.

Social Web

E-mail

E-mail It
September 14, 2005

No standard MySQL support in Postfix package

Posted in: PostFix,Unix

Bummer, I thought it was included in the default package, but somehow the configuration I used (copied from my Sun) didn’t work. I got an error message:

postfix/pickup[11145]: fatal: unsupported dictionary type: mysql

I started googling the error message and to find out how I could see which kind of lookup tables are support in the default package installed in OS X. The command I found and used was:

postconf -m

The result was that the following tables are supported:

static
sdbm
cidr
regexp
environ
proxy
btree
unix
hash

Next I will start the configuration process again from scratch to see if I can get it all working via configuration files. I hope I can get the IMAP folders working, I thought that was supported.

I can off course get the sourcecode for Postfix and recompile the whole thing to get everything working as I wanted (with MySQL support for instance) but I really would like to use standard software and not go out and compile everything myself. If someone knows of a standard package I can install like the packages for Apache, MySQL and PHP please let me know !


Return to: No standard MySQL support in Postfix package