What is this? From this page you can use the Social Web links to save Postfix problem with 10.4.8 update for Intel users to a social bookmarking site, or the E-mail form to send a link via e-mail.

Social Web

E-mail

E-mail It
October 09, 2006

Postfix problem with 10.4.8 update for Intel users

Posted in: Mac OS X,PostFix

Some of the users of my mailserver setup noticed a problem with postfix, they where unable to receive mail. When investigating the problem I found out that MySQL dictionary type was not supported by postfix. You can find this out by running 'postconf -m', mysql should be in the list.

It looks like the software update replaces our postfix binary with the original one. This is not listed in the knowledge base article so I didn’t know beforehand. I can’t confirm this problem is caused by the update, I need to research this or get more confirmations about it.

The problem is likely to only affect Intel macs, I haven’t installed everything on my Intel mac yet so I hadn’t noticed the problem yet but I didn’t have any problem on my G4 mac minis.

To solve the problem you need to reinstall postfix. If you still have the source tree intact on your harddrive you can do it quickly with just running a 'sudo make install'. If it’s no longer there then you need to recompile the source again from scratch.

Your existing configuration files won’t be touched so no worries there. Sorry I had not noticed this problem earlier. I’ll install my Intel mac mini asap to better understand what’s happening here and prevent any further problems with software updates.


Return to: Postfix problem with 10.4.8 update for Intel users