What is this? From this page you can use the Social Web links to save Upgrading the Courier-Auth module to 0.58 to a social bookmarking site, or the E-mail form to send a link via e-mail.

Social Web

E-mail

E-mail It
January 22, 2006

Upgrading the Courier-Auth module to 0.58

Posted in: Courier,News

Completely missed it, but I got a comment from Geva who mentioned an error during compilation. When I checked the error I found out that there has been an upgrade, the latest version is 0.58 instead of the 0.57 I used when I started this setup.

The related documentation has been updated and if you want to upgrade you can just download the new source-code and run the build commands as documented. Don’t forget the command:

chmod o+x /usr/local/var/spool/authdaemon

After you installed the compiled binaries. Otherwise you’ll get the error: SASL authentication failure: cannot connect to Courier authdaemond: Permission denied.

I’ve upgraded my server as soon as I found out. I found no real problems after the upgrade. the only thing I did wrong is that I forgot the chmod command myself and got the error as documented above.

I’ve subscribed myself to the Courier mailing list and others to prevent missing important updates like this and other pieces of software we use.


Return to: Upgrading the Courier-Auth module to 0.58